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1. Introduction 
Time Tracker (TT) is a PC activity monitor application for Windows. The main objective 
and the unique feature of TT is a time tracking tool that requires little user intervention. 

Ever spent the day in front of your PC, only to wonder at 5pm what you did that 
day? TT will tell you. 

TT will sit in your system tray and check every second which window is currently active 
on your desktop. The active window is the one you are currently typing or clicking in, 
and should provide an accurate estimate of what you are working on. TT captures the 
window caption from the title bar and tracks the active time for that window. 

Who wants to do the boring work of timesheets? Rules allow TT to be able to tell which 
window activity belongs to which user task automatically. Rules can be one or more 
partial window captions or file names, when any of these conditions are met, TT will start 
the task timer. When the conditions cease, TT will stop the task timer. 

TT also allows the traditional feature of manual timers. You may enter your own task 
name and either double click (or use Space or Enter) to start/stop the task timer. 

However, TT does not capture keystrokes or mouse clicks. TT does not use the Internet. 
TT does not use the Windows registry. 

The window and task active times can be saved to CSV (comma separated value) files. 

TT was designed to use very little computer resources, especially when running 
minimized. 

TT does not need to be installed, simply run the exe file. It can even run from any USB 
flash disk. The main functions of TT are available in a popup menu, right click anywhere 
in the window or on the system tray icon to display the popup menu. 

TT was tested under Windows 98, XP and Vista. It should also run under 95 and 2000. 

Basic package of Time Tracker includes the following files: 

• license.txt: A copy of the GNU General Public License, version 2.0, June 1991. 
• readme.txt: A simple readme file. 
• TaskList.txt: A list of tasks and their trigger rules. Do not edit this file directly. 
• TimeTracker.exe: Executable of the application. You can create a window short-

cut of this executable program and place the short-cut in your Windows start-up 
folder to have the application running whenever you start your computer. For 
Windows Vista, do not place the executable program under the 'Program Files' 
folder, because Windows Vista uses folder virtualization to prevent file updates in 
that folder and this would prevent the update of application settings and the 
update of output files. 

• TimeTracker.ini: Application settings. 
• TimeUsage.csv: Application output of time usage history in CSV format. 
• Uptime.csv: Application up-time in CSV format. If TT is placed in the start-up 

folder, this would be equal to your system up-time. 
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The following sections explain details of application settings, menu items, task and rule 
settings, and output data files. 

2. Basic Settings 
The application settings are stored in the 'TimeTracker.ini' file. The options that can be 
changed are: 
 

• TransparencyPercentage (preset value =30): The level of transparency of the 
application main window (Windows XP only) with 0 being non-transparent and 
100 being invisible. 

• FilterView (preset value = 0, disabled): This is the same as the Options> Filter 
Windows menu item. It displays the tasks and activities which are active within 
the recent number of seconds specified by FilterCutoffSeconds, if enabled; 
otherwise, it displays all tasks and activities tracked. 

• FilterCutoffSeconds (preset value = 120): It works with FilterView, if enabled, 
to display the tasks and activities which are active within the recent number of 
seconds. You can hide all non-task activity listing by setting the 
FilterCutoffSeconds value very high. 

• ListRefreshRateSeconds (preset value = 1): It sets the update frequency of 
displayed data, when the application is not minimized. Preset value is to refresh 
data display at every second. 

• AlwaysOnTop (preset value = 0, disabled): It is the same as the Options> Always 
On Top menu item. If enabled, the application always stays on top of other 
windows, when multiple windows are opened on your desktop. This provides the 
effect of a desktop clock. This feature is useful, if you need to use the manual 
timer feature to track your task time manually. 

• IdleCutoffSeconds (preset value = 60): It identifies the threshold, in seconds, of 
an idle task. If there is no mouse or keyboard input beyond the threshold, your 
working time is considered to be in the idle state. 

• IgnoreWindowCaptions (preset value = 0, disabled): It determines whether rules 
should be applied to Windows’ captions or not. Default setting is to apply rules to 
Windows’ captions; otherwise, if enabled, rules are applied to process file names 
only. 

• PromptWhenClosing (preset value = 1, enabled): If enabled, the application 
prompts users to save data, when users or Windows system is closing the 
application; if disabled, the application does not prompt users to save data. 

• SaveTasksOnly (preset value = 0, disabled): It is the same as the Options> Save 
Tasks Only menu item. If enabled, the applications saves only task data; 
otherwise, the application saves both task and window activity data. 

• AutoSave (preset value = 0, disabled): It is the same as the Options>Auto Save 
menu item. If enabled, the application automatically saves data without prompting 
the user, when the application is closed. 
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• ListGridLines (preset value = 1, enabled): If enabled, the application shows grid 
lines in the list view. 

• UptimeSave (preset value = 1, enabled): If enabled, the application automatically 
saves TT uptime values. 

• SaveHourFractions (preset value = 0, disabled): If enabled, in addition to time 
saved as hh:mm:ss, the application also saves time in fractions of hours. 

• LockStationAfterIdleSeconds (preset value = 0, disabled): If enabled, the 
application is able to lock your computer for you, when user’s working status 
becomes idle beyond the time limit specified by IdleCutoffSeconds. This setting 
is the same as Ctrl+Alt+Delete (available for Windows 2000, NT, XP, Vista). 
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3. Menu Items and Tabs 
When you run the application, the application is running as a background application in 
your task tray with an icon of TT. 

 
Figure 3.1: Time Tracker Running in Task Tray 

If you double click the icon, the application window pops up. If you set 
TransparencyPercentage to be a non-zero value, your application window may not be as 
clear as the images below. Also, if your window is small, you can drag any corner of the 
window to make it bigger. 

 
Figure 3.2: Time Tracker Application Window 

Your window content may be different from what are shown here, depending on your 
settings of task (which will be explained later). 

In the application window, we have 4 menu items and 3 tabs. The menu items are File, 
Options, View, and Help. The tabs are List, Tree, and Chart. 

The File menu has the following 5 menu items as shown in Figure 3.3. 

1. Load Task List: Load task list of your choice. The task list file needs to be a text 
file and in the format described in Section 4. 

2. Save Items: Save your task time in CSV format. 

3. Edit Settings: Open the application setting file, TimeTracker.ini, in a text editor 
(like Note Pad) for you to change. 
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4. Reload Settings: Reload your application settings after changes were made to the 
TimeTracker.ini file. 

5. Exit: Exit application. 

 
Figure 3.3: File Menu Items 

The Options menu has the following 5 menu items in Figure 3.4. These menu items are 
on/off switches of application features. Each of these items has a corresponding variable 
in the application settings. If a feature is enabled, you would see a check mark next to the 
feature; if disabled, the check mark is removed. 

1. Always On Top: Like AlwaysOnTop in application settings, if enabled, the 
application always stays on top of other windows, when multiple windows are 
opened on your desktop. This provides the effect of a desktop clock. This feature 
is useful, if you need to use the manual timer feature to track your task time 
manually. 

2. Filter Windows: Like FilterView in application settings, it displays the tasks and 
activities which are active within the recent number of seconds specified by 
FilterCutoffSeconds in application settings, if enabled; otherwise, it displays all 
tasks and activities tracked. 

3. Save Tasks Only: Like SaveTasksOnly in application settings, if enabled, the 
applications saves only task data; otherwise, the application saves both task and 
window activity data. 

4. Auto Save: Like AutoSave in application settings, if enabled, the application 
automatically saves data, when the application is closed. 

5. List Lines: Like ListGridLines in application settings, if enabled, the application 
shows grid lines in the list view. 

 
Figure 3.4: Options Menu Items 
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The View menu has the following 2 menu items in Figure 3.5. 

1. Refresh Now: Refresh data in active tab as shown in Figure 3.6. 

2. Clear Window Items: Clear all activity tracking data except for tasks. For 
example, Figure 3.6 shows the data in the List tab after we refresh data in the tab. 
If we click View> Clear Window Items, a window pops up as shown in Figure 3.7 
to confirm our decision to clear the window items. If we click OK, we have the 
data in Figure 3.8 for the same List tab. Note that only tasks with their usage time 
are listed in the tab as a result of the Clean Window Items. 

 
Figure 3.5: View Menu Items 

 
Figure 3.6: List Tab after Refresh 

 
Figure 3.7: Confirmation of Clear Window Items 
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Figure 3.8: List Tab after Window Items Are Cleared 

The Help menu shows the information window of the application (Figure 3.9). 

 
Figure 3.9: Test Tracker Information Window 

Next, we describe details of the List, Tree, and Chart tabs. 

The List tab provides a listing of activities and tasks, which are tracked by TT, and their 
tracking information (Figure 3.10). The tracking information includes task and activity 
names, and their duration, start time, file (module) names, and ratios to the total window 
time. 
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Figure 3.10: List Tab 

For each task, a green arrow (play) identifies an active task; a red pause sign indicates a 
non-active task. TT determines a task to be active, if its rule is triggered or the task is 
turned on manually. 

To turn on/off a task manually, you would need to highlight a task and take either of the 
following action: double-click the task, press space key, or press enter key. Once a task is 
turned off, TT resumes its tracking based on task rules. 

You can order items in this tab by clicking the header of the column which you would 
like to use to sort the items in a descending manner. 

In this tab, you can also perform additional functions through its right click menu as 
shown in Figure 3.11. 

 
Figure 3.11: Right Click Menu in List Tab 
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The right-click menu allows you to 

• Add Task: Add a new task (Section 4). 
• Remove Task: Remove a task (Section 4). 
• Add Rule: Add rules to the selected task (Section 4). 
• Go to Active Task: Go to current active task (Section 4). 
• Edit Settings: Open application settings in Note Pad for edit. 
• Reload Settings: Reload application settings from a file. 
• Exit: Exit application. 

Keyboard options are also available for these task related menu items. You can use ‘+’ or 
‘Insert’ to add a task, and ‘-‘ or ‘Del’ to remove a task. 

Section 4 will provide details of task management in TT and cover the task-related items 
in the right-click menu. 

 The Tree tab provides a listing of tasks and activities in a tree structure (Figure 3.12). In 
this window, you can do drag-and-drop activities into a task or use ‘Del’ key to remove 
activities in a task. 

 
Figure 3.12: Tree Tab 

The tab also provides right-click menu for each task or activity in the window. The right-
click menu has menu items as Expand Tree, Collapse Tree, Edit Settings, Reload Settings, 
and Exit. In the tab, you can click View> Refresh Now to refresh items in the tab and 
click View> Clear Window Items to remove activities and leave only tasks listed in the 
tab. 
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The Chart tab provides the usage time of activities in a pie chart (Figure 3.13). The tab 
provides right-click menu with menu items as Edit Settings, Reload Settings, and Exit. In 
the tab, you can click View> Refresh Now to refresh the pie chart. Since the pie chart 
does not the usage time of tasks, if you click View> Clear Window Items, you would 
simply have a blank chart. 

 
Figure 3.13: Chart Tab 

The status at the bottom of the application window shows your total up-time, when the 
application was last started, and the total up-time for the current week starting from 
Monday. Next section describes how tasks are managed in the application. 
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4. Task Management 
Task data and their trigger rules are stored in TaskList.txt by default. It is not 
recommended to edit this file directly unless you fully understand the data structure of the 
task configuration file. 

In the file, each row of data represents a task which you would like the application to 
track its usage time, when the application is running. A row starts with a task name 
followed by an equation operator and its list of trigger rules or patterns, separated by 
commas. 

Taskname="Window Caption1", "Window Caption2", "Window Caption3", "File name" 

TT will apply these patterns to your active application file names and application window 
captions. If there is a match, e.g., the patterns are substrings of active application file 
names or window captions, it turns on the tracking of the corresponding task. This is why 
they are called trigger rules. If there is a match on multiple tasks, all matching tasks are 
turned on automatically. When the match is no longer valid, the tracking of these tasks is 
turned off. The matching of trigger rules is case-sensitive. 

To add a task, you will need to use the right-click menu in the List tab by clicking Add 
Task anywhere in the tab. TT then shows you the window in Figure 4.1 for you to add a 
task. 

 
Figure 4.1: Add Task Window 

In this window, you just need to type in a new task name and optionally specify a time, if 
the task has been started for a while. 

TT does not support task category or group directory. But, this can be achieved through 
the naming of your tasks. For example, if you have E-Mail, Meeting, Training, 
Production Support, and Misc as your administrative related tasks, you can name these 
tasks as Admin:E-Mail, Admin:Meeting, Admin:Training, Admin:Production Support, 
and Admin:Misc. This way, when you use an external program or script to parse the data 
of TT, you can use the naming convention to find the total amount of time spent in 
administrative related tasks. 

A task can be removed by selecting the task that you want to remove first and then 
clicking Remove Task in the right-click menu in the List tab (Figure 4.2). The pop-up 
window then confirms your decision to remove the task. If you click Yes, the task and its 
trigger rules are removed. 
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Figure 4.2: Remove Task Window 

To add a rule to a task, you can either right click the task in the List tab and click the Add 
Rule menu item, or right click any item in the List tab and click the Add Rule menu item. 
Figure 4.3 shows you the pop-up window, when you click the Add Rule menu item. 

 
Figure 4.3: Add Rule Window 

In the Add Rule window, you can click the Task drop-down box to change the task that 
you want to add rule to. The selected task in the list tab is by default the one which rules 
are added to. Once a task is selected, you can type in the trigger rule / pattern in the New 
Rule box. The New Rule drop-down provides a list of all active activities in your 
computer. You can type in the your own trigger pattern / rule, select one from the list, or 
edit the one in the list and change it to be your own simple trigger pattern. Once you have 
your trigger pattern / rule filled out in the New Rule box, you can click the Add button to 
add the rule to other rules of the same task. If you click the Clear button, you would clear 
ALL rules defined for the task. The Save As button allows you to save all of your task 
and rule settings in the default file or in a different file. The Close button simply closes 
this window. 

Next section describes output data of the TT application. 
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5. Time Usage and Up Time 
In addition to application settings in ‘TimeTracker.ini’, the TT application creates two 
output files: 

• Uptime.csv: A log of your TT usage time, and 
• TimeUsage.csv: A log of your usage time by tasks and activities. 

Both files have data separated by commas so you can use any text editor to open and edit 
them, e.g., Note Pad, Excel, and OpenOffice. New data are appended to both files 
automatically, i.e., old data remain in both data files, if not removed manually. 

The ‘Uptime.csv’ file reports your computer usage time with the following data: Usage 
Date, Usage Week Day, Usage Start Time, Usage End Time, and Usage Time, as shown 
in Figure 5.1. 

 
Figure 5.1: Uptime.csv 

The ‘TimeUsage.csv’ reports your detailed usage time with the following data: Usage 
Date, Usage Week Day, Task Name or Window Activity Caption, Usage Time, Usage 
Start Time, and Name of window application (if the activity does not belong to any task). 

 
Figure 5.2: TimeUsage.csv 

Each session of your computer usage is separated by ‘**********’. For example, in 
Figure 5.2, the session was recorded on September 26th of 2007. During the session, the 
user spent an hour and 27 minutes on Email task, 54 minutes on Meeting, 37 minutes on 
Development, …, etc. Email task started at 1:58 pm. Meeting started at 1:54pm. There is 
a “atmgr.exe” application running at 1:18pm for 8 minutes with a window caption as 
“WebEx Meeting Manager …”. The computer was idle at 1:18pm for almost 5 minutes. 

So, if you find additional items in your ‘TimeUsage.csv’ not being included in your tasks, 
you may add them to your task rules so you can have a better tracking of your task time. 
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In summary, Task Tracker is a small window application but provides complete support 
of task tracking on your computer desktop. It supports both automatic tracking of tasks 
through task rules applied to running window activities and their window captions, and 
manual tracking of tasks through a very friendly user interface. I hope you find it to be a 
very useful tool to improve your productivity. Please feel free to send me your feedback 
at http://sourceforge.net/projects/ttracker.  

Appendices of this user guide provide a list of past software releases with their 
enhancements and a copy of the GNU GPL license for the distribution of the software. 
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Appendix 

A. Software Releases 
 
Version Release Date Release Note 
4.4.0 13 Sep. 2007 Fixed bug with system date format when calculating current week uptime. 

Fixed bug which allowed task nodes to be dragged. 
Fixed bug where time part in the tree view was also dragged. 

4.3.0 01 Sep. 2007 Implemented Feature Request (1715259) i.e. added tasks to tree view and 
added drag and drop support. 
Added INI setting: LockStationAfterIdleSeconds.  
Added DEL key functionality for tree view task nodes. 
Fixed bug when saving uptime to file. 

4.2.0 12 Aug. 2007 Added timeout to popup menu when nothing selected. 
Added error prompt when unable to save 'Uptime.csv'. 
Implemented Feature Request (1710688) i.e. removing comma characters in 
task or window names when writing to csv file. Added INI setting: SaveHour-
Fractions. 
Added display of uptime for the current week. 

4.1.0 22 April 2007 Fixed bug where the application prevented shutdown. 
Fixed sorting of list columns when items have the same name. 
Fixed flickering in the status bar. 
Added Started column to the list view.  
Added Start and End times to 'Uptime.csv'.  
Added Start times to 'TimeUsage.csv'. 
Added Find Active Task to popup menu (F3). 
Added started task name as system tray hint. 

4.0.0 15 April 2007 Major release. 
Changed look&feel to match Windows Task Manager. 
Added elapsed time to Add Item dialog. 
Changed list view to "virtual" mode to improve performance for a large 
number of items. 
Added tree and chart view (for window items only). 

3.3.0 22 March 2007 Fixed critical window handle leak. 
Added different system tray icons for when a task has started. 
Added Edit INI to popup menu. 

3.2.0 19 March 2007 CSV file items are now sorted according to time. 
CSV file window items are now also filtered  selected on the popup menu. 
Added Uptime.csv file. 
Fixed popup menu items when minimized. 
Added detailed error messages when loading task list fails. 

3.1.0 10 March 2007 Close button now minimizes the window. 
Added branding to popup menu. 
Prevented duplicate entries for a new rule. 

3.0.0 03 March 2007 This is the initial public release. 
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B. GNU GPL License 
 
The GNU General Public License (GPL) 
Version 2, June 1991 
 
Copyright (C) 1989, 1991 Free Software Foundation, Inc. 
59 Temple Place, Suite 330, Boston, MA 02111-1307 USA 
 
Everyone is permitted to copy and distribute verbatim copies 
of this license document, but changing it is not allowed. 
 
Preamble 
 
The licenses for most software are designed to take away your freedom to share and change it. By contrast, 
the GNU General Public License is intended to guarantee your freedom to share and change free software--
to make sure the software is free for all its users. This General Public License applies to most of the Free 
Software Foundation's software and to any other program whose authors commit to using it. (Some other 
Free Software Foundation software is covered by the GNU Library General Public License instead.) You 
can apply it to your programs, too. 
 
When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are 
designed to make sure that you have the freedom to distribute copies of free software (and charge for this 
service if you wish), that you receive source code or can get it if you want it, that you can change the 
software or use pieces of it in new free programs; and that you know you can do these things. 
 
To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask 
you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute 
copies of the software, or if you modify it. 
 
For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the 
recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. 
And you must show them these terms so they know their rights. 
 
We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives 
you legal permission to copy, distribute and/or modify the software. 
 
Also, for each author's protection and ours, we want to make certain that everyone understands that there is 
no warranty for this free software. If the software is modified by someone else and passed on, we want its 
recipients to know that what they have is not the original, so that any problems introduced by others will 
not reflect on the original authors' reputations. 
 
Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that 
redistributors of a free program will individually obtain patent licenses, in effect making the program 
proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use 
or not licensed at all. 
 
The precise terms and conditions for copying, distribution and modification follow. 
 
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION 
 
0. This License applies to any program or other work which contains a notice placed by the copyright 
holder saying it may be distributed under the terms of this General Public License. The "Program", below, 
refers to any such program or work, and a "work based on the Program" means either the Program or any 
derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either 
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verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included 
without limitation in the term "modification".) Each licensee is addressed as "you". 
 
Activities other than copying, distribution and modification are not covered by this License; they are 
outside its scope. The act of running the Program is not restricted, and the output from the Program is 
covered only if its contents constitute a work based on the Program (independent of having been made by 
running the Program). Whether that is true depends on what the Program does. 
 
1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any 
medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright 
notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of 
any warranty; and give any other recipients of the Program a copy of this License along with the Program. 
 
You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty 
protection in exchange for a fee. 
 
2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on 
the Program, and copy and distribute such modifications or work under the terms of Section 1 above, 
provided that you also meet all of these conditions: 
 
    a) You must cause the modified files to carry prominent notices stating that you changed the files and the 
date of any change. 
 
    b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived 
from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the 
terms of this License. 
 
    c) If the modified program normally reads commands interactively when run, you must cause it, when 
started running for such interactive use in the most ordinary way, to print or display an announcement 
including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you 
provide a warranty) and that users may redistribute the program under these conditions, and telling the user 
how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally 
print such an announcement, your work based on the Program is not required to print an announcement.) 
 
These requirements apply to the modified work as a whole. If identifiable sections of that work are not 
derived from the Program, and can be reasonably considered independent and separate works in themselves, 
then this License, and its terms, do not apply to those sections when you distribute them as separate works. 
But when you distribute the same sections as part of a whole which is a work based on the Program, the 
distribution of the whole must be on the terms of this License, whose permissions for other licensees extend 
to the entire whole, and thus to each and every part regardless of who wrote it. 
 
Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; 
rather, the intent is to exercise the right to control the distribution of derivative or collective works based on 
the Program. 
 
In addition, mere aggregation of another work not based on the Program with the Program (or with a work 
based on the Program) on a volume of a storage or distribution medium does not bring the other work under 
the scope of this License. 
 
3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or 
executable form under the terms of Sections 1 and 2 above provided that you also do one of the following: 
 
    a) Accompany it with the complete corresponding machine-readable source code, which must be 
distributed under the terms of Sections 1 and 2 above on a medium customarily used for software 
interchange; or, 
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    b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge 
no more than your cost of physically performing source distribution, a complete machine-readable copy of 
the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium 
customarily used for software interchange; or, 
 
    c) Accompany it with the information you received as to the offer to distribute corresponding source 
code. (This alternative is allowed only for noncommercial distribution and only if you received the program 
in object code or executable form with such an offer, in accord with Subsection b above.) 
 
The source code for a work means the preferred form of the work for making modifications to it. For an 
executable work, complete source code means all the source code for all modules it contains, plus any 
associated interface definition files, plus the scripts used to control compilation and installation of the 
executable. However, as a special exception, the source code distributed need not include anything that is 
normally distributed (in either source or binary form) with the major components (compiler, kernel, and so 
on) of the operating system on which the executable runs, unless that component itself accompanies the 
executable. 
 
If distribution of executable or object code is made by offering access to copy from a designated place, then 
offering equivalent access to copy the source code from the same place counts as distribution of the source 
code, even though third parties are not compelled to copy the source along with the object code. 
 
4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this 
License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will 
automatically terminate your rights under this License. However, parties who have received copies, or 
rights, from you under this License will not have their licenses terminated so long as such parties remain in 
full compliance. 
 
5. You are not required to accept this License, since you have not signed it. However, nothing else grants 
you permission to modify or distribute the Program or its derivative works. These actions are prohibited by 
law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work 
based on the Program), you indicate your acceptance of this License to do so, and all its terms and 
conditions for copying, distributing or modifying the Program or works based on it. 
 
6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically 
receives a license from the original licensor to copy, distribute or modify the Program subject to these 
terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights 
granted herein. You are not responsible for enforcing compliance by third parties to this License. 
 
7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not 
limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) 
that contradict the conditions of this License, they do not excuse you from the conditions of this License. If 
you cannot distribute so as to satisfy simultaneously your obligations under this License and any other 
pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a 
patent license would not permit royalty-free redistribution of the Program by all those who receive copies 
directly or indirectly through you, then the only way you could satisfy both it and this License would be to 
refrain entirely from distribution of the Program. 
 
If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance 
of the section is intended to apply and the section as a whole is intended to apply in other circumstances. 
 
It is not the purpose of this section to induce you to infringe any patents or other property right claims or to 
contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free 
software distribution system, which is implemented by public license practices. Many people have made 
generous contributions to the wide range of software distributed through that system in reliance on 
consistent application of that system; it is up to the author/donor to decide if he or she is willing to 
distribute software through any other system and a licensee cannot impose that choice. 
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This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this 
License. 
 
8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by 
copyrighted interfaces, the original copyright holder who places the Program under this License may add 
an explicit geographical distribution limitation excluding those countries, so that distribution is permitted 
only in or among countries not thus excluded. In such case, this License incorporates the limitation as if 
written in the body of this License. 
 
9. The Free Software Foundation may publish revised and/or new versions of the General Public License 
from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail 
to address new problems or concerns. 
 
Each version is given a distinguishing version number. If the Program specifies a version number of this 
License which applies to it and "any later version", you have the option of following the terms and 
conditions either of that version or of any later version published by the Free Software Foundation. If the 
Program does not specify a version number of this License, you may choose any version ever published by 
the Free Software Foundation. 
 
10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions 
are different, write to the author to ask for permission. For software which is copyrighted by the Free 
Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our 
decision will be guided by the two goals of preserving the free status of all derivatives of our free software 
and of promoting the sharing and reuse of software generally. 
 
NO WARRANTY 
 
11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR 
THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN 
OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES 
PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED 
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO 
THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE 
PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, 
REPAIR OR CORRECTION. 
 
12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING 
WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR 
REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, 
INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT 
LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES 
SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE 
WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
 
END OF TERMS AND CONDITIONS 
 
How to Apply These Terms to Your New Programs 
 
If you develop a new program, and you want it to be of the greatest possible use to the public, the best way 
to achieve this is to make it free software which everyone can redistribute and change under these terms. 
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To do so, attach the following notices to the program. It is safest to attach them to the start of each source 
file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" 
line and a pointer to where the full notice is found. 
 
    One line to give the program's name and a brief idea of what it does. 
    Copyright (C) <year> <name of author> 
 
    This program is free software; you can redistribute it and/or modify it under the terms of the GNU 
General Public License as published by the Free Software Foundation; either version 2 of the License, or 
(at your option) any later version. 
 
    This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; 
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR 
PURPOSE. See the GNU General Public License for more details. 
 
    You should have received a copy of the GNU General Public License along with this program; if not, 
write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA 
 
Also add information on how to contact you by electronic and paper mail. 
 
If the program is interactive, make it output a short notice like this when it starts in an interactive mode: 
 
    Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY 
NO WARRANTY; for details type `show w'. This is free software, and you are welcome to redistribute it 
under certain conditions; type `show c' for details. 
 
The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public 
License. Of course, the commands you use may be called something other than `show w' and `show c'; they 
could even be mouse-clicks or menu items--whatever suits your program. 
 
You should also get your employer (if you work as a programmer) or your school, if any, to sign a 
"copyright disclaimer" for the program, if necessary. Here is a sample; alter the names: 
 
    Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision' (which makes 
passes at compilers) written by James Hacker. 
 
    signature of Ty Coon, 1 April 1989 
    Ty Coon, President of Vice 
 
This General Public License does not permit incorporating your program into proprietary programs. If your 
program is a subroutine library, you may consider it more useful to permit linking proprietary applications 
with the library. If this is what you want to do, use the GNU Library General Public License instead of this 
License. 
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